Recent Changes

Saturday, July 8

  1. page home edited ... This WIKI Has been granted Education Status! 10-25-2014 cap47 It is restricted to 100 members …
    ...
    This WIKI Has been granted Education Status! 10-25-2014 cap47 It is restricted to 100 members by Wikispaces. Dormant members have been purged to meet the new requirements and new members can be added on a case by case admission! You all can still view and use our WIKI content. If you have content to add, you can request to be added as a member by Emailing a description of your content to an Organizer! Must be new content. We have room for 32 new members with new ideas. This step had to be taken to insure continuation of the WIKI!
    Welcome to the Ultimate-Guitar Valveking Only Wikispace! Limited membership of 100 users max..
    If you don't give a valid reason to become a member you will be denied because of the above Limit we have to stay under. You are still able to browse and use content .
    The Discussion Page is no longer active. Go to the Valveking thread for any discussion.
    THIS SITE WILL BE CHECKED AND EDITED ACCORDINGLY WITH NEW INFORMATION.
    (view changes)
    12:49 pm

Saturday, February 18

  1. msg Peavey Valveking 20 MH footswitch issue message posted Peavey Valveking 20 MH footswitch issue Hello there, I'm new to this forum. I'd like to ask some help to fix the "volume issue" …
    Peavey Valveking 20 MH footswitch issue
    Hello there, I'm new to this forum.
    I'd like to ask some help to fix the "volume issue" when you plug the footswitch in a Valveking 20 MH.
    In my case only the channel switching works (ring), while the boos function doesent work properly.
    When you plug a footswitch you will notice a dramatic loss in overall volume and by pressing the other switch (tip) the overall volume falls so you have the perception to increase the volume by pressing the boost function (the volume comes back to mormal).
    In reality the boost function in the fron panel works in a complitely different way indeed....it adds some mid and treble frequencies and a slight increase in volume.
    I just want to do with the footswitch what I normally do with the button in the front panel (without the footswitch plugged in).
    Could someone please help me?

    P.S.: I have the original schematic

    Thank you so much in advance
    9:28 am

Friday, October 7

Wednesday, June 22

  1. msg EL34 tube mod message posted EL34 tube mod Having acquired a VK100, I wanted to look at a few of the mods you can do to this amp. Mods applies…
    EL34 tube mod
    Having acquired a VK100, I wanted to look at a few of the mods you can do to this amp. Mods applies so far are: 1 the bypass of one gain stage in the lead channel to get a more Marshall tone, 2. a switch to lift the cathode on two of the output tubes, and 3. a bias pot so that I can fit EL34s. It all worked fine - for a while. Now I'm finding the preamp tubes are dropping like flies, particularly the phase splitter.

    Having looked at various posts on the subject, the received wisdom seems to be that all that is required is a re-bias of the output tubes. However, my reading of the schematic is that there is a potential problem with the the way the heaters are wired in the VK100. Specifically, the 6L6s draw 900mA and the output tubes are wired in series before feeding into the (presumably nominal) 6v line across the three 12AX7s in parallel. The 12AX7s are rated at 300mA so they should also draw 900mA in parallel. By my reckoning, that should put the voltage of HTR at around 30v, although it's not marked on the schematic, EL34s, however, draw 1.5A of heater current. Again,a basic calculation suggests that, assuming an HTR of around 30v, you're going to get around 1.3A of heater current (and the 6v line will therefore actually be at around 8.8v).

    Does that sound right and is that why my 12AX7s are suffering? I will be putting the 6L6s back to compare but would be grateful for any thoughts in the meantime.
    3:27 pm

Tuesday, June 7

  1. msg valveking 112 issues message posted valveking 112 issues my valveking's volume control must be bad, turning it up just a little bit past all the way down wi…
    valveking 112 issues
    my valveking's volume control must be bad, turning it up just a little bit past all the way down will skyrocket the volume and trying to fine tune it will make a lot of crackling noises...what gives?

    also, whenever i try to use the loop, a screeching feedback come on.

    my speakers are new. this has been happening since i bought the amp
    3:21 pm

Saturday, May 7

  1. msg Can you run 5581 power tubes safely? message posted Can you run 5581 power tubes safely? You mean 5881 tubes and they would have to stand 460V Plate Current. I don't think they would work.…
    Can you run 5581 power tubes safely?
    You mean 5881 tubes and they would have to stand 460V Plate Current. I don't think they would work. I don't think they would damage the amp. The only thing that might happen is the tubes would burn out if voltage is too high. I would not recommend using them. RCA manual says 400 plate volts max.
    11:57 am

More